electron 怎么使用beanstalked包

在electron项目下安装了npm install --save beanstalkd

看样例直接使用的是import Beanstalkd from 'beanstalkd';
import Beanstalkd from 'beanstalkd';

   ^^^^^^^^^^

SyntaxError: Unexpected identifier

运行时出现这样的错误,怎么才能支持import

最佳答案

不知道怎么用babel,小白一个
随便找个别人的样例,这样就可以了
npm install @babel/core @babel/plugin-proposal-class-properties @babel/plugin-transform-runtime @babel/preset-env @babel/register @babel/runtime
安装好写babel的配置文件 .babelrc,内容如下:

{
  "presets": ["@babel/preset-env"],
  "plugins":["@babel/proposal-class-properties",
      [
      "@babel/plugin-transform-runtime",
      {
        "corejs": false,
        "helpers": true,
        "regenerator": true,
        "useESModules": true
      }
    ]
  ]
}

package.json 启动脚本 改成"start": "electron -r @babel/register ."